Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

I think I bricked my blinky tape

so everything was going great!
I had just sodered on some more neopixels ( same version that the blinky tape uses)
added about 20 more. should be no problem right?

and you'd be right. they worked beautifully.

made a couple sketches.

then when I went to upload a sketch, the paint sketch froze and crashed first time this has happened

Once I plug in the blinky tape, it begins to play my sketch but extremely fast.
It won't connect to the computer anymore.

then it keeps playing fast and fast each time I plug it in. ( bout 3x as I tried to reset it.)

then it stopped turning on at all.

most of the leds flash for a second when I plug em in... but I can't seem to figure out how to fix it.

I saw on another thread that I could chain up to 500 but should stay in the 200 range.. figured i'd be totally fine..

please help... I have another blinky tape somewhere that I guess im going to take apart and resoder my other peices back on ( worked on it for like 6 hours atleast so I don't wanna start over.)

I was so proud of what I made.... now its totally tanked from some software issue..

please help me.

Comments

  • edited January 2017

    Hi there- sounds like a fun project, and sorry that it's crashing on you. Have you tried restoring the firmware on it? On the troubleshooting page:
    http://blinkinlabs.com/blinkytape/troubleshooting/

    follow the steps under 'try restoring the firmware'

  • yup> @Matt Mets said:

    Hi there- sounds like a fun project, and sorry that it's crashing on you. Have you tried restoring the firmware on it? On the troubleshooting page:
    http://blinkinlabs.com/blinkytape/troubleshooting/

    follow the steps under 'try restoring the firmware'

    yup I even did the second reset version for the kickstarter tapes.

    bootloader isn't loading onto the tape..

    =(

  • Hmm, that's frustrating. Have you had any luck with it yet?

    If not, can you fill me in on the details of your setup- particulary, what operating system you are using, and which version of Pattern Paint?

  • Yeah actually I bought two more blinky tape microcontrollers. Did the same thing to the other blinky tape I have and totally bricked it.

    I have the newest version of windows. same with pattern paint.
    2.1.3

    so what happens is this.
    I put in a couple of animations.
    it works when plugged into my pc.
    then when I click to upload, it freezes about 20% thought the download.
    freezes on the leds too.
    then nothing will load.
    last time I had it on that screen for like 5 mins waiting for it.

    this time I shut it down immediately, hoping it wouldn't fry the micro controller.

    is there a limit to how many patterns you can put on the micro controller? I know there is a data limit but I haven't seen anything displayed saying I'm using too many bytes.

    the only option I changed was from the scene to 80 leds from 60.

    the first three animations have always worked but when I load another it crashes and bricks the controller.

    Now I have one more Teensy unit... but Im terrified that I'm going to brink this one by loading in a new sketch...

    Please..

    how is this happening and why?

    I thought this software was supposed to work with the controller?

    I only have 20 additional LEDs on the controller and I heard that It can handle 500.
    it works going all night so I know its not surging it. seems like the byte conversion when putting into the CPU overloads it.

  • You really did a great work.

  • For anyone who's having a similar issue, please update to a new version of PatternPaint, this issue was addressed a while ago:
    http://blinkinlabs.com/blinkytape/patternpaint/

Sign In or Register to comment.