Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

BlinkyTape not connecting to PatternPaint

edited December 2013 in BlinkyTape Fun
I can't get the BlinkyTape to connect to PatternPaint. The default pattern displays, but clicking "connect" in PatternPaint doesn't do anything. Sys info:
Pattern Paint 0.2.0
Build Date: Dec 9 2013 00:49:05
Operating system: OS X 10.8 (Mountain Lion)
QT information:
Build Date: Sun Aug 25 2013
Path: /Applications/
Detected BlinkyTapes:
Detected BlinkyTape Bootloaders:
Detected Serial Ports:
Description: incoming port - Bluetooth-Serial-1
VID: 0x0
PID: 0x0
Description: incoming port - Bluetooth-Serial-2
VID: 0x0
PID: 0x0
Description: Bluetooth-Modem
VID: 0x0
PID: 0x0
Description: incoming port - Bluetooth-PDA-Sync
VID: 0x0
PID: 0x0

Thanks for the help!


  • Oh, sorry it isn't working for you! It looks like the BlinkyTape isn't being picked up as a serial port. My guess is that either one of the data connections in the cable are bad, or perhaps the USB connector on the board has an issue. Do you have another USB cable you could try with it? If that doesn't work, we'll send out a replacement.
  • I had the same problem after nothing I did could bring the BT back to life. Then I had an idea, hold the button on the BT and then press CONNECT in PATTERN PAINT (PP)! It worked! BT is talking to PP BUT, the BT doesn't respond to what I load or draw or try to upload using PP??? All LEDs are on almost full brightness until I tried to load ColorSwirl with Adruino 1.05. Sketch hung and didn't cure the all lights on (until unplugging BT). Further, I found Arduino IDE was locked up (pleasantly the BT was seen by the Serial Port without me having to do the hold-switch-plug-USB-in routine. Something's wrong somewhere?

    I force quit both PP (also frozen) and Arduino, restarted PP and again had to hold the BT button while pressing CONNECT. BT was seen but is non-responsive to drawing REAL TIME (as it had been in the previous Processor version). I am assuming I should be seeing the tape light up as soon as I paint a pixel, BUT NOT A DROP OF LIGHT doth the BT emit :(

    Ah HA! I have to hold the BT BUTTON in while connecting the USB in order for PP to connect and start scanning…. HOWEVER when I draw, nothing happens in the BT, I press SAVE 2 TAPE: the progress bar window saying SAVING ANIMATION TO BT drops down but no BLUE PROGRESS BAR APPEARS, the BT remains black and the saving window goes away, scanning restarts with my little squiggle on the screen but NOTHING GETS LOADED TO BT WHICH REMAINS BLACK. Got any ideas?

    Another observation: I can press the connect and disconnect buttons in PP without the holding BT button (to me meaning I've tricked PP into thinking the tape is connected, but in reality is nowhere to be found.
  • Now in Arduino, tape is recognized, color swirl uploaded, this error message gave one LED (#26 from chip) flickering, then suddenly all LEDS lit full brightness in varying hue's until as mysteriously, the lights extinguished as I was in Safari typing this!? Huh?

    ERROR IN Arduino reads:

    Binary sketch size: 9,336 bytes (of a 28,672 byte maximum) Couldn’t find a Leonardo on the selected port. Check that you have the correct port selected. If it is correct, try pressing the board's reset button after initiating the upload.

    now suddenly, the BT comes alive again and begins its random flicker (VIDEO: then after a time, extinguishes never to light again ;(

    BTW, Arduino "sees it" without fiddling, but NOT REALLY as it hangs when uploading, then freezes or just hangs and doesn't complete upload of color swirl.
  • That flickering is really weird - let's see if Matt has any thoughts on this issue. It's a new one to us.
  • I was having the same issue - my BT (just received it) wasn't showing up as a USB serial device. The third USB cable I tried worked, no ides what was wrong with the other 2 as both provided power to the BT just fine.
  • Glad the third one worked. Did the included cable have a problem?

    Some cell phone charging cables only have the power wires connected, and won't work for data transmission.
Sign In or Register to comment.