Pattern Paint working intermitantly

I am having trouble with getting Pattern Paint to work fully for me.

Sometimes it works great and other times when I connect using the app, nothing happens. It says it is connected but doesn't actually give me the live update.

Do I need a specific sketch to be uploaded before Pattern Paint to recognize that the App is running?

I have tried restarting the app, different USB ports etc.

Do I need to use the button on the blinky for to start it?




  • Hi Phil,

    OK - so you're running the self-contained version of PatternPaint, from here:

    But sometimes when you connect, it doesn't do anything? And sometimes it I have this right?

    You don't need to run anything in Processing to get this to work. It is possible to put a new sketch on the tape via the Arduino environment that could lack the code to talk to PatternPaint. Did you put a different sketch onto the tape using Arduino?

    My other question is: do you have any other hardware that connects via a USB-serial, like a 3d printer or bitcoin miner?
  • Hi, so I am using the standalone Pattern Paint.

    I didn't have any other USB devices.

    I have been trying other examples from your Arduino library.

    What sketch should I upload to make it accept data from Pattern Paint?


  • Ah ok - Colorswirl should work. Try that and let us know.
  • I loaded ColorSwirl and it cycles through the colors ok. When I run PatternPaint and hit connect the cycle freezes but the strip stays illuminated in it's frozen state.

    When I draw in PatternPaint nothing happens.

    If I powercycle the BlinkyTape color cycle starts up again.

    Driving me nuts...


  • Hi Phil,

    Hmm, it definitely sounds like something is off. There's a new version of PatternPaint, at the same link as before -- please try that. It also has functionality to restore the factory firmware; I would recommend trying that also.
  • Hi Phil,

    Maybe we're over-thinking this - do you have a different USB cable that you could try with? Maybe it's just a loose connection...
  • I'll try and different cable and different Mac today too.

    I'll report back.


  • Ok, I tried a different cable and different Mac.

    Weird thing is I can upload Arduino sketches no problem.

    It just freezes when I hit connect in Pattern Paint
  • I just tried a few other Processing sketches and get the same result.

    I loaded Disco Party and when I hit connect, it froze the current sequence that is running on the blinky tape.

  • Any more thoughts on my issue?


  • Hi Phil,

    I'm really sorry, I had composed a message yesterday but I must not have clicked "post."

    Matt and I are both a bit stumped, but can you email us at - might be time to swap your tape out but I want to make sure Matt has a good look at this thread first. Btw, which version of OS X are you running?
  • I'm running 10.7.5

    I'll email now.
  • The BT has mysteriously stopped working. It shows in Arduino but sketch hangs near end and reports the error LEONARDO Can't be found. Pattern Paint (the latest version) attempt to reset firmware does nothing? BTW, can you post screen captures anywhere in this forum? Here's the error I get:
Sign In or Register to comment.