blinkytape won't work on battery, only while Patternpaint is connected

I've started having an issue with my Blinkytape - it seems work just fine while it's plugged into the computer and running Patternpaint. It appears to behave normally when downloading a pattern. However, when I unplug it and connect to the battery pack, It flickers momentarily while being connected, but then is dark and seems dead.

Any ideas what the problem is and if it can be reset somehow?



  • Hmm- do you know the capacity of the battery? Flickering like that could possibly mean the BlinkyTape is drawing too much current, and causing the battery pack to go into current protection mode and shut off. Has it worked with the battery before? Do you have a different USB charger (like from a cell phone) that you can use to test the tape with?

    Another thought would be to try restoring the original firmware on the tape (in Pattern Paint, choose 'tools->restore rainbow sketch'), to see if that affects the output.
  • hello - The battery pack is the one I got in the kit when I purchased it through kickstarter. It always worked fine until just a couple weeks ago.
    I did try another USB power brick and get the same effect - a brief blink as it's being plugged in, but otherwise no signs of life.
    The restore rainbow command in the menu doesn't seem to have any effect. it goes through the motions with the progress bar, but doesn't actually load the rainbow.
    Any other ideas to troubleshoot?
  • I forgot to mention- I can't actually save any patterns to the tape's memory. Things only work while plugged into the computer and running pattern paint, but as soon as I exit the program, the animation freezes. once I disconnect from USB, nothing will happen when plugging back into the computer or any usb power source, until I start pattern paint again. It comes up with a blank pattern, and I need to draw or load a new one for anything to happen on the tape.
  • That's quite an interesting issue. Is there any chance you have Arduino installed? My next suggestion would be to try programming it with something besides Pattern Paint, in case something stopped working with the PatternPaint uploader. Which OS are you using?

    Can you try uploading the 'ProductionSketch' example using Arduino?
  • The same thing is happening to me. Works fine when attached to my old Macbook Pro running Windows 7. But on my new Surface Book running Windows 10 - all seems good until I turn off Pattern Paint and that's the end of that...

  • Hi Terry- did you click the 'save to blinky' button before closing PatternPaint? Did the upload process report any errors?

    If so, you might also need to unplug the tape and plug it back in- some earlier versions of PatternPaint don't tell the tape to re-start it's animation process automatically.

  • Save to Blinky appears to run fine with no errors reported but as soon as I close Pattern Paint the animation freezes and the tape goes dark when I unplug and plug back in. This is now happening with my Windows 7 machine where it worked fine last week...

  • Hmm, very interesting... what version of PatternPaint are you using?

  • Version 1.8.0 - nothing changed since last week when it worked - also tried rebooting the computer with Blinky Tape plugged in - same results...

  • Can you try the latest preview release? Apologies that it stopped working for you.

    I've made some fairly significant updates to the firmware and to PatternPaint since 1.8.0, if it was getting stuck on something in the firmware, the new version might help.

  • I seem to be missing something basic... upgraded to the new version - created my own pattern - works fine when plugged in - but I can't get rid of lazer cat and that's what ends up being saved to tape no matter what I do - how do I get rid of the sample patterns so I can save just my own? Are there directions somewhere??

  • To get rid of the laser cat pattern (and other samples), click on their thumbnail photo on the left hand side of the screen, then select file->close to close them. You can also press 'cancel' on the welcome screen to skip loading them. Does the tape play back patterns by itself now?

    That cat has to go though, it's a placeholder while we look for some more interesting examples.

  • Whew! finally... I had tried to close laser cat but it kept giving me an error message - worked this time though. And I seem to be programmed in red and green for the holidays. Thanks

  • Yaay! Hoping to get this version 2.0 out in the next couple of days (blinkytape support seems fine, but blinkytile and the blinkypendant drivers need a little more work), and then get some documentation in. If you have any suggestions or run into any other issues please let me know so we can make this an easier to use program.

Sign In or Register to comment.