BT Controller DOA (sort of) ?

Hi all,
Received the Blinky S Tape and JST BT controller today.
I plugged it into a USB cable and then into my Anker powerbank, it cycled through the rainbow, all was well.

Tried to demonstrate it later in the day, same method. Nothing.
Plugged in to Laptop (Windows 7, PP 2.2) Not recognised.
Doesn't seem to be taking any power.

I've tried holding down the button when plugging in, but that has no effect.

Any ideas?



  • I have now also tested this at home. Multiple usb cables tried, multiple power sources. Tried my PC which is windows 10, tried both pp 2.2 and 2.0 after seeing previous threads.
    Still doesn't take any power and so I can't do anything with the firmware.

  • Hmm, sorry it isn't working- that's pretty strange behavior. To confirm, did you do anything besides plug it in before it stopped working (such as load a new pattern or upload a new firmware)? Also, can you try plugging just the controller into your computer, without the strip attached?

  • I had only plugged it in to my Anker, which gives 5V 3A for output, and it cycled through the rainbow pattern fine.
    After that, all I had done was to disconnect and pop it back in the packet before taking out later in the afternoon to repeat the same. And it didn't light up.
    It was only after that I started testing it on USB ports and installing PP to see if that would register its connection.

    I have just tried connecting the controller by itself to my PC, same lack of response.

  • I've ordered a new controller from the EU supplier. Here's hoping the first one was just bad luck.

  • It works! Looks like the original one I got was faulty.

  • edited May 2017

    Thought I had another issue, but don't. All LEDs firing on PC, Anker and any other device I plug it in to.

  • Glad that you got it going- please send us an email at:, and we can get you a replacement for the broken controller.

Sign In or Register to comment.