Unknown USB Device (Device Descriptor Request Failed)

I have a couple BlinkyMatrix devices I haven't used in about a year, and am having a USB driver issue with one of them that I don't think I have ever used. I get the USB driver error: "Windows has stopped this device because it has reported problems. (Code 43) A request for the USB device descriptor failed," when I connect to my Win10 machine. I tried uninstalling the driver in device manager, uninstalling PatternPaint, and downloading the latest version, but still no love. I also looked for a driver in the blinkytape folder to manually install, but couldn't find one. The board connected to the matrix is Blinky Tape Rev H, 11/2013. I didn't have any issues with another Matrix that has been previously used.

Any recommendations would be greatly appreciated.


  • I forgot about the restore firmware trick of selecting “restore firmware” in Pattern Paint, and then holding down the white button on the driver board while plugging in the USB cable. That did the trick.

  • Thanks for the update- glad to hear you were able to get it going, and sorry that it wasn't working right away.

Sign In or Register to comment.