Trouble connecting via Arduino IDE on Windows + workaround solution

At first I wasn't able to connect and upload programs from the Arduino IDE to the BlinkyBoard. I figured out that if I connected using PatternPaint and uploaded a file to the BlinkyBoard, immediately after I could upload using the Arduino IDE. Unfortunately, after I've connected and uploaded with the Arduino IDE I can't connect connect again until I've uploaded another image via PatternPaint. I'm guessing PatternPaint is resetting something to allow Arduino IDE connections again and/or something about the Arduino IDE (or the content I'm uploading) breaks things. Anyways, give this a shot if you're having trouble connecting using the Arduino IDE.

Note: Uploading blank images via PatternPaint, ie the default empty black that's there when you start the program, is apparently enough to re-enable connections. This saves me a few clicks compared to selecting and loading an actual file each time I want to upload new code.


  • Very interesting -- thanks for sharing. So you had to start running both programs at the same time to get it to work?

    We've heard that sometimes multiple COM ports are being created on Windows, so it might be an issue that you could solve by re-scanning the serials ports in the Arduino IDE, though maybe you've tried that. At any rate, thank you for bringing this up.
  • datdat
    edited January 2014
    Yeah I keep both programs open. This is what my workflow has been:

    - update code in Arduino IDE
    - switch to Pattern Paint window
    - hit "Connect" button
    - hit "Save to Tape" button
    - switch back to Arduino IDE window
    - hit Arduino IDE upload button
    - observe lights
    - repeat

    I tried monitoring the COM port number changes and accounting for those, but that doesn't seem to help with the Arduino IDE like it did when I was getting DiscoParty to work in Processing. Priming the BlinkyBoard with a PatternPaint upload is the only way I've gotten the Arduino IDE to upload. Otherwise it times out and says the upload has failed.

    Here's a screenshot of the failed upload message:
  • Hmmm...when I've had that message, I would always get it to work by closing any other programs that might be talking to the serial port (i.e. PatternPaint) then unplugging the BlinkyTape. When I'd plug it back in, it would be good to go. Had you tried that?
  • To find out what is having a handle open to a serial port under Windows, the best solution is to use Process Explorer's "Find Handle" function.
    The process is described here:
Sign In or Register to comment.