Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

DiscoParty Error: Cannot find a class or type named "Burst"

edited December 2013 in BlinkyTape Fun
Hi all,

I followed the instructions to try to get DiscoParty to run, and I get the error: Cannot find a class or type named "Burst"

What should I do?

Thanks!

Comments

  • I found that I was able to get DiscoParty working by copying the Burst class out of the 'experimental>DiscoParty_Burst' Example into DiscoParty
  • Thanks, I think the files have been updated. I opened the new "Burst" example, but I get this error now:

    DiscoParty[panel0,14,0,100x200,invalid,layout=java.awt.BorderLayout]
    ==== JavaSound Minim Error ====
    ==== Error acquiring TargetDataLine: line with format PCM_SIGNED 44100.0 Hz, 16 bit, stereo, 4 bytes/frame, little-endian not supported.

    Any thoughts on that?

    Thanks
  • Hmm...that's weird. What OS and version are you running? We haven't seen this one yet. It might indicate that there's a conflict opening the sound input source.
  • edited December 2013
    Running Windows 7 Ultimate 64 bit. That probably happened because I was using Skype at the same time :P

    But I now get this message: DiscoParty[panel0,14,0,100x200,invalid,layout=java.awt.BorderLayout]

    Any thoughts on that one?

    Edit: I noticed it's halfway working. The display opened up and is getting input from the mic, but the Blinkytape is still running its default pattern. Seems like I'm halfway there!

    Edit 2: I didn't realize I had to install Pattern Paint which has the driver. Hopefully it'll work now!
  • edited December 2013
    Well, I still can't get it to work. Driver is installed along with Pattern Paint. Pattern Paint seems to work.

    Discoparty opens up a display and gets input from the mic, but the Blinkytape doesn't receive the data. This message still appears in Processing: DiscoParty[panel0,14,0,100x200,invalid,layout=java.awt.BorderLayout]

    Edit: Ok, I got it to work by following the method here: http://forums.blinkinlabs.com/index.php?p=/discussion/45/blinkytape-doesn039t-connect-with-discoparty-or-ambitape

    Can a fix be made so the COM port doesn't need to be changed everytime? Thanks!
  • Hi again - so it sounds like you did the font-size fix? Hmm...it seems like saving the serial port should be possible, though it might take a little work to make it work nicely. Or maybe we just put in an option to hard-code the port...
  • edited December 2013
    Hi,

    Thanks for your help. I did the COM port fix, and saved that. That's the only change I made. For some reason it stopped working one time, but I went back later and it started working again.

    How would it work if I want to connect 2 Blinkytapes for a stereo pair of speakers? I mean just having 2 going at the same time, not that each one needs to receive different data.
  • Actually if you're using the code I suggested, it's not too difficult. You can change the line that says:

    if(p.startsWith("/dev/cu.usbmodem")) {

    to something like:

    if(p.startsWith("COMx") || p.startsWith("COMy")) {

    We're going to continue work on this, and hopefully the programs will support multiple strips out of the box.
  • Thanks, but now it's not working again. I unplugged and replugged it, and the default pattern is playing, but I can't get it to connect with either Processing or Pattern Paint.

    Let me know what you'd suggest. Thanks.
  • Is this after making the change I suggested or did it just stop working even with the version you had up and running?
  • I didn't do this, if that's what you mean:

    if(p.startsWith("/dev/cu.usbmodem")) {

    to something like:

    if(p.startsWith("COMx") || p.startsWith("COMy")) {

    I only have 1 Blinkytape at the moment, although I'd like to get another one.


    Yeah, it stopped working, although it was working before. I left it unplugged for about a day, and plugged it back in. I'm able to connect to Pattern Paint now, and am currently using DiscoParty. Any ideas why it seems to be flaky, and what to do about it?

    Also, I still get this message: DiscoParty[panel0,14,0,100x200,invalid,layout=java.awt.BorderLayout] but it works.
  • Yes, that's what I meant. Thanks for the info.

    It's weird that it started working again without chaning anything - did you reboot your computer during the day it was sitting? Or does it seem like the USB connector is flaky if you jiggle the connector? (I.E. does the strip go black if you move it around?) Keep us posted if this happens again - if it's something that you can fix with a reboot, it's probably nothing to worry about. You can always email support@blinkinlabs.com if the problem gets worse.

    I think you can ignore the DiscoParty java error for now, we'll be updating that to better support Win machines with lots of ports and building multi-strip support too.
  • dat
    edited December 2013
    I've noticed the COM port changes depending on what port you plug it into, and it also changes sometimes for no reason on my computer. It has ranged from 8 to 15. I use Windows 7 Professional 64 bit. This has caused DiscoParty to work intermittently for me. I went into Device Manager and manually set the BlinkyTape COM port to 9, under Ports (COM & LPT) > BlinkyTape > Port Settings > Advanced. That seemed to make the connection process more consistent.
  • Thanks for the tip, dat- Windows does indeed change the COM port depending on which USB port you plug it into. Setting it manually is an interesting idea.

    Out of curiosity, does PatternPaint correctly connect to the BlinkyTape, regardless of where it's plugged in? We're using a different serial library there that should only show *active* serial devices.
  • Matt, for me PatternPaint seems to work independent of whichever USB port I plug into on my Windows laptop
  • Great, thanks dat. I wish there was a simple way to use the serial library from Qt in Processing, it would make a lot of this stuff less of a pain!
Sign In or Register to comment.