Blinky EightbyEight woes


I am on a Macbook Air 2015 running Sierra. I have an EightbyEight blinky that on the back says 2016. I am using PatternPaint 2.4.1.

Every time I try to download a file from PatternPaint to the Blinky it says Error Message: Command getFirmwareVersion timed out. I had apparently been able to Restore the Firmware and download the file, but when unplugged, the Blinky would just go dark and then play the default Beer animation instead of the one I was trying to add.

After that “success” I tried following instructions I found in the forum to use the Terminal to update firmware to 1.0.1 and it went back to giving me the same error message (Command getFirmwareVersion timed out) and when I try the Restore Firmware from inside PatternPaint again it seems to be doing it, but it doesn’t seem to change anything and I get the same error.

I thought using the PatternPaint app would allow me not to have to use the Arduino IDE and would be an all in one solution to just add quick animations to the Blinky. Am I wrong?

I’ve tried to read through other posts and understand how to fix this, but I’ll be honest: I am a total noob and got lost reading the instructions. (ARM? Homebrew?) It is very overwhelming for something I thought was going to be very easy to work with.

Any (step-by-step) suggestions of things to try?


  • edited September 2018


    I'm having the exact same problem, and I'm a super noob. I'm using a EightByEight Blinky and have a macbook pro running OSX 10.9.5. This is the message that keeps popping up, and I don't know what I'm doing wrong.:

    Error Message: Got unexpected data back command name: getFirmwareVersion position: 0 expected: 0 received: e0 mask: ff

    I tried to reset the firmware, and this is the message I get for that:

    Error Message: Command SyncFrame timed out

    What do I need to do to get the Sync to work?


Sign In or Register to comment.